It is currently Sat Jun 23, 2018 1:09 am

AVO injury!

 
Posts: 149
Joined: Sat Jan 14, 2012 9:53 pm
Location: Westcliff On Sea

AVO injury!

Post by TNC » Fri May 01, 2015 10:01 am

Like an idiot, I have managed to apply 350 DC volts to my AVO whilst it was on the 0-10 volt setting.
Before I start to dismantle, can someone please advose whether there is a fusing system in the meter or is
it a hopeless case
Thanks,

Trevor. :ccb

 
Posts: 86
Joined: Sun May 13, 2012 3:15 pm

Re: AVO injury!

Post by boyblue » Fri May 01, 2015 10:25 am

Hi Trevor, later 8s have a fuse in the battery compartment. not sure if its just for the ohms ranges though. Worth a look

Peter

 
Posts: 149
Joined: Sat Jan 14, 2012 9:53 pm
Location: Westcliff On Sea

Re: AVO injury!

Post by TNC » Fri May 01, 2015 12:24 pm

Thanks chaps for your thoughts...fuses OK so looked bad...but then, with the meter upside-down, the cut-out that was previously part hidden by the very fat, rubberised probe terminals, was visible...and out it had popped...clearly an excellent design...what a relief!

Thanks again...& will try to be more careful! :)

 
Posts: 311
Joined: Sat Feb 09, 2013 6:08 pm
Location: due South of Selby, near the Pepperpots, house smells of two stroke.

Re: AVO injury!

Post by Wolfie » Fri May 01, 2015 12:42 pm

I bet you didn't realise that it had a backlight? (albeit very brief). :qq1

Glad it was an easy fix


Return to General Work Shop Discussion



Who is online

Users browsing this forum: No registered users and 1 guest